[Webkit-unassigned] [Bug 11401] Drosera doesn't understand object.method = function() {} syntax
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Oct 24 14:26:42 PDT 2006
http://bugs.webkit.org/show_bug.cgi?id=11401
bdash at webkit.org changed:
What |Removed |Added
----------------------------------------------------------------------------
Ever Confirmed|0 |1
Status|UNCONFIRMED |NEW
CC| |bdash at webkit.org
------- Comment #1 from bdash at webkit.org 2006-10-24 14:26 PDT -------
It is obvious why this is desirable, but what is less obvious is the difficulty
in providing this. At the time the function object is created, it is
anonymous. Assigning it to a variable or to property on another object does
not change this fact. Consider the following example:
SomeObject.someMethod = function(a, b) { };
SomeOtherObject.someOtherMethod = SomeObject.someMethod;
SomeOtherObject.someOtherMethod(1, 2);
What name should Drosera give to the frame created by the function call in the
third line? Coming up with a solution to this single case appears relatively
easy, but is tricky to generalise in a fashion that won't produce more
confusing results in some cases.
--
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list