[Webkit-unassigned] [Bug 9596] [Drosera] add a function popup to the source pane

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 1 11:25:29 PST 2006


http://bugs.webkit.org/show_bug.cgi?id=9596


timothy at hatcher.name changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #11317|review?                     |review-
               Flag|                            |




------- Comment #4 from timothy at hatcher.name  2006-11-01 11:25 PDT -------
(From update of attachment 11317)
This is looking good. There are a few things that need addressed.

Many elese statments do not meet our style guidlines.

+                    }
+                    else

Place the else on the same line as the end brace.

+                    } else

+                    result += "<span class=\"keyword\">" + "<a
name=\"function-" 

These first two strings can be combined into one, eliminating a concatination.

+    var functionNames = new Array();

Why have a local functionNames when you just use file. functionNames?

+                    var counter = 8;

Rename that to functionKeywordOffset or something meaningful. The current name
is confusing.

Please use "<No selected symbol>", like Xcode. Note the missing spaces and the
capital No.

removeChildrenFromElement should be a prototype function on Element and just
called removeChildren. There are a couple of functions we add to element for
adding and removing class names.

I am not big fan of the red highlight around the function name, lets just
remove that. Xcode dosen't do that.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list