[Webkit-unassigned] [Bug 8910] Various code cleanups in RenderBox

bugzilla-daemon at opendarwin.org bugzilla-daemon at opendarwin.org
Sun May 14 20:23:44 PDT 2006


darin at apple.com changed:

           What    |Removed                     |Added
   Attachment #8312|review?                     |review-
               Flag|                            |

------- Comment #2 from darin at apple.com  2006-05-14 20:23 PDT -------
(From update of attachment 8312)
I'm not fond of adding parentheses around the equality comparisons in if
statements. I don't like formatting where a continued if condition has the same
indenting level as the code that will execute if the if is true. I typically
indent the if condition an extra level to avoid this.

In headers, I like leaving out the parameter name if it's completely redundant
with the type, so all those "WidthType widthType" should just be "WidthType".

+            int maxW =  calcWidthUsing(MaxWidth, containerWidth);

Two spaces here after the = sign, should just be one.

I don't understand why we'd set m_marginLeft and m_marginRight to 0 just before
setting them inside the width.isAuto() case. Can those lines go inside the

The changes look good otherwise. I like the continued cleanup of
calcWidthUsing. I'm tempted to say review+, but since this is all about style I
think I'll say review- for the m_marginLeft/Right thing if for nowthing else.

Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list