[Webkit-unassigned] [Bug 3439] mouseover effects can get stuck sometimes due to missing events

bugzilla-daemon at opendarwin.org bugzilla-daemon at opendarwin.org
Sun Mar 19 08:31:12 PST 2006


http://bugzilla.opendarwin.org/show_bug.cgi?id=3439


darin at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
   Attachment #7169|review?                     |review-
               Flag|                            |




------- Comment #12 from darin at apple.com  2006-03-19 08:31 PDT -------
(From update of attachment 7169)
I like the general direction of this patch a lot.

But I don't like the idea of adding the subframe function to
MouseEventWithHitTestResults. It's fine to have that helper function, but I
don't think it should be a member function of the event class. I think we can
just have a local function in FrameView.cpp (not a member of any class) that
takes the mouse event or node as a parameter. Might need a clearer name than
"subframe", or "subframe" might be OK.

+            if (m_oldUnder && m_oldUnder->getDocument() !=
frame()->document())

In the check above, do we also want to check inDocument() on m_oldUnder?

Does FrameView::dispatchMouseEvent handle the case where targetNode is
destroyed as a side effect of handling the mouseout or mouseover event? I think
we may need to ref it.

By the way, the "pass subframe event to subframe" code might need to be moved
into FrameView eventually -- the strange way this code is distributed across
FrameView and Frame is an artifact of us not wanting to modify the KHTML code
much in the old days (so we put stuff in KWQKHTMLPart, now the
Macintosh-specific part of Frame).

Setting review- mainly because of the subframe function, but please also
consider the other comments.


-- 
Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list