[Webkit-unassigned] [Bug 3233] CSS2: Web Kit does not support the :lang pseudo-class
bugzilla-daemon at opendarwin.org
bugzilla-daemon at opendarwin.org
Sun Jun 4 11:42:35 PDT 2006
http://bugzilla.opendarwin.org/show_bug.cgi?id=3233
------- Comment #15 from contact at nickshanks.com 2006-06-04 11:42 PDT -------
Replacing the NOTFUNCTION token results in this:
| ':' 'n' 'o' 't' '(' maybe_space simple_selector ')' {
CSSParser* p = static_cast<CSSParser*>(parser);
$$ = p->createFloatingSelector();
$$->match = CSSSelector::PseudoClass;
$$->simpleSelector = p->sinkFloatingSelector($7);
$$->value = atomicString("not(");
}
and means that it can't be used for anything else one day (CSS4?). I suggest
leaving the token in the lexicon but calling it SIMPLEFUNCTION instead.
--
Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list