[Webkit-unassigned] [Bug 6279] New: Patch: give internal function names (KJS merge)

bugzilla-daemon at opendarwin.org bugzilla-daemon at opendarwin.org
Wed Dec 28 14:54:57 PST 2005


           Summary: Patch: give internal function names (KJS merge)
           Product: WebKit
           Version: 412+
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: JavaScript
        AssignedTo: webkit-unassigned at opendarwin.org
        ReportedBy: maksim at kde.org

The attached is a preliminary patch to give builtin functions names, and have 
them print out in the way mozilla and KJS testsuites expect (mostly --- some 
mozilla testcases has a requirement on body indenting, but this fixes a 
couple). I'll probably rediff it against actual JSC later on. 
This basically does: 
-Move keeping track of name into InternalFunctionImp 
-Set the name when grabbing functions from hashtable 
-Set the name of manual managed properties by hand 
-Use the name when printing internal functions 
Based on the work done by David Faure.

Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list