[Webkit-unassigned] [Bug 3233] CSS2: Web Kit does not support the :lang pseudo-class

bugzilla-daemon at opendarwin.org bugzilla-daemon at opendarwin.org
Wed Dec 28 02:06:59 PST 2005


macdome at opendarwin.org changed:

           What    |Removed                     |Added
   Attachment #2388|                            |review-
               Flag|                            |

------- Additional Comments From macdome at opendarwin.org  2005-12-28 02:06 -------
(From update of attachment 2388)
In general, I think this patch is good.  A couple comments:

1. I think that your additional "string-arg" member variable for CSSSelector
shoudl either be part of a union with simpleSelector, or should be part of a
subclass of CSSSelector.  Either way, we should only pay 4bytes for
simpleSelector and string_arg (bad name, btw) not 8, like we currently are.

Second, I think that NOTFUNCTION can just be replaced by "not(" in the actual
grammar if you like.

No need to add any //kdDebug lines, we're removing those as we go.

When we go about adding nth-* selectors, I don't think we'll keep the string
value in CSSSelector (we might).  We'll probably have bison do the actual an+b
parsing for us, and store a,b on CSSSelector (or more likely a subclass) as
floats perhaps.

Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list