[webkit-reviews] review granted: [Bug 246051] [Outline] Outline painting should be able to call BorderPainter with border-radius info : [Attachment 462800] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 5 07:52:52 PDT 2022


Antti Koivisto <koivisto at iki.fi> has granted  review:
Bug 246051: [Outline] Outline painting should be able to call BorderPainter
with border-radius info
https://bugs.webkit.org/show_bug.cgi?id=246051

Attachment 462800: Patch

https://bugs.webkit.org/attachment.cgi?id=462800&action=review




--- Comment #2 from Antti Koivisto <koivisto at iki.fi> ---
Comment on attachment 462800
  --> https://bugs.webkit.org/attachment.cgi?id=462800
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=462800&action=review

> Source/WebCore/rendering/BorderPainter.h:47
> +    struct Sides {
> +	   RoundedRect outerBorder;
> +	   RoundedRect innerBorder;
> +	   RoundedRect unadjustedInnerBorder;
> +	   std::optional<BorderData::Radii> radii { };
> +	   const BorderEdges& edges;
> +	   bool haveAllSolidEdges { true };
> +	   BackgroundBleedAvoidance bleedAvoidance { BackgroundBleedNone };
> +	   bool includeLogicalLeftEdge { true };
> +	   bool includeLogicalRightEdge { true };
> +	   bool appliedClipAlready { false };
> +    };

"Sides" seems like a strange name for this. I'd expect it would have four sides
as a member or something. I don't have a suggestion though.


More information about the webkit-reviews mailing list