[webkit-reviews] review granted: [Bug 238375] Add support for element.computedStyleMap() : [Attachment 456208] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 31 17:08:50 PDT 2022


Alex Christensen <achristensen at apple.com> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 238375: Add support for element.computedStyleMap()
https://bugs.webkit.org/show_bug.cgi?id=238375

Attachment 456208: Patch

https://bugs.webkit.org/attachment.cgi?id=456208&action=review




--- Comment #12 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 456208
  --> https://bugs.webkit.org/attachment.cgi?id=456208
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=456208&action=review

> Source/WebCore/css/CSSComputedStyleDeclaration.h:60
> +    enum class PropertyValueType { Resolved, Computed };

nit
: bool

> Source/WebCore/css/typedom/ComputedStylePropertyMapReadOnly.cpp:67
> +ExceptionOr<Vector<RefPtr<CSSStyleValue>>>
ComputedStylePropertyMapReadOnly::getAll(const String& property) const

This is mostly duplicate code.	Could you factor the shared logic into a helper
function?

> Source/WebCore/css/typedom/ComputedStylePropertyMapReadOnly.cpp:102
> +Vector<StylePropertyMapReadOnly::StylePropertyMapEntry>
ComputedStylePropertyMapReadOnly::entries() const

Could you add a few spec links in this file?  There is some interesting logic.


More information about the webkit-reviews mailing list