[webkit-reviews] review granted: [Bug 233202] Web Inspector: [Cocoa] Indicate a request was sent through private relay in Network tab : [Attachment 455832] Patch v1.0

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 28 09:50:09 PDT 2022


Devin Rousso <drousso at apple.com> has granted Patrick Angle <pangle at apple.com>'s
request for review:
Bug 233202: Web Inspector: [Cocoa] Indicate a request was sent through private
relay in Network tab
https://bugs.webkit.org/show_bug.cgi?id=233202

Attachment 455832: Patch v1.0

https://bugs.webkit.org/attachment.cgi?id=455832&action=review




--- Comment #8 from Devin Rousso <drousso at apple.com> ---
Comment on attachment 455832
  --> https://bugs.webkit.org/attachment.cgi?id=455832
Patch v1.0

View in context: https://bugs.webkit.org/attachment.cgi?id=455832&action=review

r=me, neat!

> Source/WebCore/platform/network/NetworkLoadMetrics.h:137
> +    bool isProxyConnection;

Is this perhaps already covered by `PrivacyStance::Proxied`?

> Source/WebInspectorUI/UserInterface/Models/Resource.js:388
> +	   return this._isProxyConnection ? WI.UIString("%s (Proxy)", "%s
(Proxy) @ Resource Remote Address", "Label for the IP address of a proxy server
used to retrieve a network resource.").format(this._remoteAddress) :
this._remoteAddress;

Style: I'd split this onto separate lines.
```
if (this._isProxyConnection)
    return WI.UIString("%s (Proxy)", "%s (Proxy) @ Resource Remote Address",
"Label for the IP address of a proxy server used to retrieve a network
resource.").format(this._remoteAddress);

return this._remoteAddress;
```

> Source/WebKit/NetworkProcess/cocoa/NetworkSessionCocoa.mm:906
> +	       additionalMetrics->isProxyConnection = m.proxyConnection;

eww `m.`?  That could've used a better name :(


More information about the webkit-reviews mailing list