[webkit-reviews] review granted: [Bug 237567] [WebAuthn] Support authenticatorSelection.residentKey ResidentKeyRequirement : [Attachment 454138] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 9 14:59:20 PST 2022


Brent Fulgham <bfulgham at webkit.org> has granted j_pascoe at apple.com
<j_pascoe at apple.com>'s request for review:
Bug 237567: [WebAuthn] Support authenticatorSelection.residentKey
ResidentKeyRequirement
https://bugs.webkit.org/show_bug.cgi?id=237567

Attachment 454138: Patch

https://bugs.webkit.org/attachment.cgi?id=454138&action=review




--- Comment #4 from Brent Fulgham <bfulgham at webkit.org> ---
Comment on attachment 454138
  --> https://bugs.webkit.org/attachment.cgi?id=454138
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=454138&action=review

The logic looks good, but I think some of the naming could be clearer.

> Source/WebCore/Modules/webauthn/PublicKeyCredentialCreationOptions.h:69
> +	   std::optional<ResidentKeyRequirement> residentKey;

Suggeste calling this "residentKeyRequirement", or just "keyRequirement"

> Source/WebCore/Modules/webauthn/PublicKeyCredentialCreationOptions.idl:75
> +    ResidentKeyRequirement	    residentKey;

Ditto "residentKeyRequirement" or "keyRequirement"

> Source/WebKit/UIProcess/API/Cocoa/_WKAuthenticatorSelectionCriteria.h:45
> + at property (nonatomic) _WKResidentKeyRequirement residentKey;

Should this be named "residentKeyRequirement"? You aren't returning the key --
you are returning the key requirement.

> Source/WebKit/UIProcess/API/Cocoa/_WKWebAuthenticationPanel.mm:738
> +static std::optional<WebCore::ResidentKeyRequirement>
residentKey(_WKResidentKeyRequirement uv)

I think we often name things like this "toWebCore()".


More information about the webkit-reviews mailing list