[webkit-reviews] review granted: [Bug 237267] Introduce routines to exchange SharedVideoFrame::Buffer directly : [Attachment 453497] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 2 08:28:44 PST 2022


Eric Carlson <eric.carlson at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 237267: Introduce routines to exchange SharedVideoFrame::Buffer directly
https://bugs.webkit.org/show_bug.cgi?id=237267

Attachment 453497: Patch

https://bugs.webkit.org/attachment.cgi?id=453497&action=review




--- Comment #6 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 453497
  --> https://bugs.webkit.org/attachment.cgi?id=453497
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=453497&action=review

> Source/WebKit/GPUProcess/media/RemoteVideoFrameObjectHeap.cpp:109
> +    auto videoFrame = get(WTFMove(read));

Obviously this isn't new to this patch, but reading this made me realize that
RemoteVideoFrameObjectHeap::get is a confusing name because `get` RefPtr::get
and Ref::get are so widely used in WebKit and don't mean the same thing at all.

> Source/WebKit/GPUProcess/webrtc/LibWebRTCCodecsProxy.mm:248
> +	      
m_videoFrameObjectHeap->get(WTFMove(std::get<RemoteVideoFrameReadReference>(sha
redVideoFrame.buffer)));

Ditto.


More information about the webkit-reviews mailing list