[webkit-reviews] review granted: [Bug 234988] Disable CFURLCache in WebKit2 : [Attachment 449681] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Jan 21 14:57:44 PST 2022
Geoffrey Garen <ggaren at apple.com> has granted Sihui Liu <sihui_liu at apple.com>'s
request for review:
Bug 234988: Disable CFURLCache in WebKit2
https://bugs.webkit.org/show_bug.cgi?id=234988
Attachment 449681: Patch
https://bugs.webkit.org/attachment.cgi?id=449681&action=review
--- Comment #5 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 449681
--> https://bugs.webkit.org/attachment.cgi?id=449681
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=449681&action=review
r=me
I added some style comments.
> Source/WebCore/PAL/pal/spi/cf/CFNetworkSPI.h:362
> +void _CFURLStorageSessionDisableCache(CFURLStorageSessionRef);
Can we make this declaration conditional on HAVE(CFNETWORK_DISABLE_CACHE_SPI)?
That way you get an easier to understand compiler error, rather than a linker
error, if you try to use this function when you shouldn't.
> Source/WebCore/platform/network/NetworkStorageSession.h:123
> + enum class ShouldDisableURLCache : bool { No, Yes };
I would call this ShouldDisableCFURLCache, since we still enable the WebCore
URL cache even when this is true.
> Source/WebCore/platform/network/cf/NetworkStorageSessionCFNet.cpp:49
> + bool isCacheDisabled = false;
Can we just use the shouldDisableURLCache parameter instead of tracking this
boolean separately?
> Source/WebCore/platform/network/cocoa/NetworkStorageSessionCocoa.mm:184
> + bool isCacheDisabled = false;
Can we just use the shouldDisableURLCache parameter instead of tracking this
boolean separately?
More information about the webkit-reviews
mailing list