[webkit-reviews] review granted: [Bug 235175] [css-contain] Fix contain-size-replaced-002.html : [Attachment 449151] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 14 03:11:56 PST 2022

Manuel Rego Casasnovas <rego at igalia.com> has granted Rob Buis
<rbuis at igalia.com>'s request for review:
Bug 235175: [css-contain] Fix contain-size-replaced-002.html

Attachment 449151: Patch


--- Comment #7 from Manuel Rego Casasnovas <rego at igalia.com> ---
Comment on attachment 449151
  --> https://bugs.webkit.org/attachment.cgi?id=449151

View in context: https://bugs.webkit.org/attachment.cgi?id=449151&action=review


> Source/WebCore/rendering/svg/LegacyRenderSVGRoot.cpp:269
> +    if (clipViewport && contentSize().isEmpty())
> +	   return;

One question, should we move this up on the method, to avoid doing other checks
that might not be needed?

More information about the webkit-reviews mailing list