[webkit-reviews] review granted: [Bug 235003] Use IsNegation bit for more efficient pseudo-class style invalidation : [Attachment 448670] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jan 8 10:17:21 PST 2022


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Antti Koivisto
<koivisto at iki.fi>'s request for review:
Bug 235003: Use IsNegation bit for more efficient pseudo-class style
invalidation
https://bugs.webkit.org/show_bug.cgi?id=235003

Attachment 448670: Patch

https://bugs.webkit.org/attachment.cgi?id=448670&action=review




--- Comment #4 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 448670
  --> https://bugs.webkit.org/attachment.cgi?id=448670
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=448670&action=review

> Source/WebCore/ChangeLog:8
> +	   We now know is an invaliation ruleset is for negated context. We can
use this to avoid

Does not parse

> Source/WebCore/dom/Element.cpp:799
> +	   Style::PseudoClassChangeInvalidation styleInvalidation(*this,
CSSSelector::PseudoClassActive, flag, invalidationScope);

flag needs a better name

> Source/WebCore/dom/Element.cpp:851
> +    Style::PseudoClassChangeInvalidation focusStyleInvalidation(*this, { {
CSSSelector::PseudoClassFocus, flag }, { CSSSelector::PseudoClassFocusVisible,
flag } });

Ditto

> Source/WebCore/dom/Element.cpp:887
> +	   Style::PseudoClassChangeInvalidation styleInvalidation(*this,
CSSSelector::PseudoClassFocusWithin, flag);

Ditto

> Source/WebCore/dom/Element.cpp:897
> +	   Style::PseudoClassChangeInvalidation styleInvalidation(*this,
CSSSelector::PseudoClassHover, flag, invalidationScope);

Ditto

> Source/WebCore/dom/Element.cpp:910
> +    Style::PseudoClassChangeInvalidation styleInvalidation(*this,
CSSSelector::PseudoClassDrag, flag);

Ditto

> Source/WebCore/html/HTMLInputElement.cpp:978
> -void HTMLInputElement::setChecked(bool nowChecked)
> +void HTMLInputElement::setChecked(bool newChecked)

The rename doesn't really help. why not just isChecked or checked?


More information about the webkit-reviews mailing list