[webkit-reviews] review granted: [Bug 237192] [InputElement] Add HTMLInputElement::showPicker() method : [Attachment 453414] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 28 13:15:12 PST 2022


Darin Adler <darin at apple.com> has granted zsun at igalia.com's request for review:
Bug 237192: [InputElement] Add HTMLInputElement::showPicker() method
https://bugs.webkit.org/show_bug.cgi?id=237192

Attachment 453414: Patch

https://bugs.webkit.org/attachment.cgi?id=453414&action=review




--- Comment #5 from Darin Adler <darin at apple.com> ---
Comment on attachment 453414
  --> https://bugs.webkit.org/attachment.cgi?id=453414
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=453414&action=review

> Source/WebCore/html/ColorInputType.h:69
> +    void openPopupView() final;

WebCore::Chrome calls this operation "run the open panel", now this new
function calls it "open the pop-up view", and the new public DOM standard
function calls it "show the picker". I don’t think it’s valuable to have three
different sets of terminology for this in WebKit. Can we get closer to one set
of terminology? I don’t mind changing the existing ones if they should be
changed. I’d prefer that this function not use a third term, if we can avoid
it, unless there’s an important distinction we are expressing.

> Source/WebCore/html/HTMLInputElement.cpp:1298
> +	       return Exception { SecurityError,
"HTMLInputElement::showPicker() called from cross-origin iframe." };

Is this the format that we use for function names in these kinds of exceptions?
HTMLInputElement::showPicker() looks natural to a C++ programmer, but maybe not
so much to a web programmer using JavaScript?


More information about the webkit-reviews mailing list