[webkit-reviews] review granted: [Bug 236268] [WebAssembly][Modules] Support Wasm module loading in WebCore : [Attachment 452803] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 21 17:52:15 PST 2022


Yusuke Suzuki <ysuzuki at apple.com> has granted Asumu Takikawa
<asumu at igalia.com>'s request for review:
Bug 236268: [WebAssembly][Modules] Support Wasm module loading in WebCore
https://bugs.webkit.org/show_bug.cgi?id=236268

Attachment 452803: Patch

https://bugs.webkit.org/attachment.cgi?id=452803&action=review




--- Comment #25 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 452803
  --> https://bugs.webkit.org/attachment.cgi?id=452803
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=452803&action=review

r=me

> Source/JavaScriptCore/parser/SourceProvider.h:140
> +	   virtual void initBuffer() { }
> +	   virtual void cleanupBuffer() { }

Maybe, lockUnderlyingBuffer / unlockUnderlyingBuffer would be better names.

> Source/JavaScriptCore/wasm/js/JSWebAssemblyHelpers.h:66
>      auto throwScope = DECLARE_THROW_SCOPE(vm);

Let's take const WebAssemblySourceProviderBufferGuard& parameter to ensure that
this is called after ensuring that. (Like `const AbstractLocker&` parameter)

> Source/WebCore/bindings/js/WebAssemblyCachedScriptSourceProvider.h:40
> +class WebAssemblyCachedScriptSourceProvider : public
JSC::BaseWebAssemblySourceProvider, public CachedResourceClient {

Let's put `final`'

> Source/WebCore/bindings/js/WebAssemblyCachedScriptSourceProvider.h:69
> +    {

Let's add `ASSERT(!m_buffer)`

> Source/WebCore/bindings/js/WebAssemblyCachedScriptSourceProvider.h:74
> +    {

Let's add `ASSERT(m_buffer)`


More information about the webkit-reviews mailing list