[webkit-reviews] review granted: [Bug 236868] Provide a WebCore subspaceImplFor template to make code more readable. : [Attachment 452596] proposed patch.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 18 16:22:10 PST 2022


Yusuke Suzuki <ysuzuki at apple.com> has granted Mark Lam <mark.lam at apple.com>'s
request for review:
Bug 236868: Provide a WebCore subspaceImplFor template to make code more
readable.
https://bugs.webkit.org/show_bug.cgi?id=236868

Attachment 452596: proposed patch.

https://bugs.webkit.org/attachment.cgi?id=452596&action=review




--- Comment #3 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 452596
  --> https://bugs.webkit.org/attachment.cgi?id=452596
proposed patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=452596&action=review

r=me

> Source/WebCore/bindings/js/WebCoreJSClientData.h:204
> +    auto* clientSpace = new JSC::GCClient::IsoSubspace(*space);
> +    setClient(clientSubspaces,
std::unique_ptr<JSC::GCClient::IsoSubspace>(clientSpace));

why not using makeUnique<> ?


More information about the webkit-reviews mailing list