[webkit-reviews] review granted: [Bug 236037] Wasm crash on https://copy.sh/v86/?profile=dsl : [Attachment 451165] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 7 17:11:59 PST 2022


Mark Lam <mark.lam at apple.com> has granted Saam Barati <sbarati at apple.com>'s
request for review:
Bug 236037: Wasm crash on https://copy.sh/v86/?profile=dsl
https://bugs.webkit.org/show_bug.cgi?id=236037

Attachment 451165: patch

https://bugs.webkit.org/attachment.cgi?id=451165&action=review




--- Comment #19 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 451165
  --> https://bugs.webkit.org/attachment.cgi?id=451165
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=451165&action=review

r=me

> Source/JavaScriptCore/ChangeLog:22
> +	   mov x16, k
> +	   mov x16, k2
> +	   mov x1, [x16]
> +	   mov zr, [x16]

Did you mean this instead?
```
    mov k, x16
    mov k2, x16
    mov x1, [x16]
    mov zr, [x16]
```
I find this example confusing: the first 2 instructions imply the dest is the
left operand, while the last 2 instructions imply that the dest is the right
operand.  Can you make it consistent?

> Source/JavaScriptCore/ChangeLog:28
> +	   mov x16, k
> +	   mov x1, [x16]
> +	   mov x16, k2
> +	   mov zr, [x16]

Ditto.


More information about the webkit-reviews mailing list