[webkit-reviews] review denied: [Bug 236054] Add support for parsing 'subgrid' in grid-template-columns/row : [Attachment 450731] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 3 05:07:58 PST 2022


Darin Adler <darin at apple.com> has denied Matt Woodrow <mattwoodrow at apple.com>'s
request for review:
Bug 236054: Add support for parsing 'subgrid' in grid-template-columns/row
https://bugs.webkit.org/show_bug.cgi?id=236054

Attachment 450731: Patch

https://bugs.webkit.org/attachment.cgi?id=450731&action=review




--- Comment #3 from Darin Adler <darin at apple.com> ---
Comment on attachment 450731
  --> https://bugs.webkit.org/attachment.cgi?id=450731
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=450731&action=review

Need a rebased patch that works in EWS

> Source/WebCore/css/parser/CSSPropertyParser.cpp:3685
> +    RefPtr<CSSGridLineNamesValue> lineNames = consumeGridLineNames(args,
nullptr, true);

auto

> Source/WebCore/css/parser/CSSPropertyParser.cpp:3707
> +	   RefPtr<CSSValueList> values = CSSSubgridValue::create();

auto

> Source/WebCore/css/parser/CSSPropertyParser.cpp:3712
> +	       } else if (RefPtr<CSSValue> value = consumeGridLineNames(range,
nullptr, true))

auto

> Source/WebCore/rendering/style/RenderStyle.h:1775
> +    static bool initialGridSubgrid() { return false; }

Why go the trouble of using a function here. It only share one for rows and
columns?

> Source/WebCore/rendering/style/StyleGridData.h:106
> +    bool subgridRows;

Can we just initialize to false here instead of using the cumbersome
RenderStyle approach?

> Source/WebCore/style/StyleBuilderConverter.h:1007
> +    bool m_isSubgrid { false };

This whole struct uses incorrect coding style. Public struct members should not
have m_ prefixes.


More information about the webkit-reviews mailing list