[webkit-reviews] review granted: [Bug 239799] Avoid sending a flush IPC to the GPU process when destroying a RemoteImageBuffer : [Attachment 458415] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 26 22:39:46 PDT 2022


Said Abou-Hallawa <sabouhallawa at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 239799: Avoid sending a flush IPC to the GPU process when destroying a
RemoteImageBuffer
https://bugs.webkit.org/show_bug.cgi?id=239799

Attachment 458415: Patch

https://bugs.webkit.org/attachment.cgi?id=458415&action=review




--- Comment #2 from Said Abou-Hallawa <sabouhallawa at apple.com> ---
Comment on attachment 458415
  --> https://bugs.webkit.org/attachment.cgi?id=458415
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=458415&action=review

> Source/WebCore/ChangeLog:8
> +	   No new tests (OOPS!).

This should be removed before landing.

> Source/WebCore/platform/graphics/ImageBuffer.h:101
> +    virtual bool flushDrawingContextAsync() { return false; }

It is not clear from the name what this function returns. Should it be renamed
flushDrawingContextAsyncIfNeeded()?

> Source/WebKit/WebProcess/GPU/graphics/RemoteImageBufferProxy.h:313
> +	   return false;

The order in this function is a little bit hard to read. Can't it be rearranged
like this:

// Nothing to flush, return true if we need the caller to wait.
if (!m_remoteDisplayList.needsFlush())
    return hasPendingFlush();

// Do the flushing and tell the caller to wait.
...
m_remoteDisplayList.flushContext(m_sentFlushIdentifier);
...
return true;


More information about the webkit-reviews mailing list