[webkit-reviews] review granted: [Bug 118009] user-select: none shouldn't affect editability : [Attachment 457879] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 19 06:10:17 PDT 2022


Antti Koivisto <koivisto at iki.fi> has granted Tim Nguyen (:ntim)
<ntim at apple.com>'s request for review:
Bug 118009: user-select: none shouldn't affect editability
https://bugs.webkit.org/show_bug.cgi?id=118009

Attachment 457879: Patch

https://bugs.webkit.org/attachment.cgi?id=457879&action=review




--- Comment #8 from Antti Koivisto <koivisto at iki.fi> ---
Comment on attachment 457879
  --> https://bugs.webkit.org/attachment.cgi?id=457879
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=457879&action=review

> Source/WebCore/rendering/style/RenderStyle.h:630
> +    UserSelect effectiveUserSelect() const { return effectiveInert() ?
UserSelect::None : (userModify() == UserModify::ReadOnly ? userSelect() :
UserSelect::Text); }

Maybe just move this out-of-line and make it multiline with ifs? Nested ternary
operators are difficult to read.

> LayoutTests/ChangeLog:9
> +	   - Added new tests for new behavior (imported from the Blink
codebase)

Is a WPT possible?


More information about the webkit-reviews mailing list