[webkit-reviews] review granted: [Bug 237554] Unify 'transform-box' reference box computation : [Attachment 456751] Patch, v10

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 6 14:46:22 PDT 2022


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Nikolas Zimmermann
<zimmermann at kde.org>'s request for review:
Bug 237554: Unify 'transform-box' reference box computation
https://bugs.webkit.org/show_bug.cgi?id=237554

Attachment 456751: Patch, v10

https://bugs.webkit.org/attachment.cgi?id=456751&action=review




--- Comment #36 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 456751
  --> https://bugs.webkit.org/attachment.cgi?id=456751
Patch, v10

View in context: https://bugs.webkit.org/attachment.cgi?id=456751&action=review

> Source/WebCore/rendering/RenderLayer.h:701
> +    // Returns the 'reference box' used for clipping operations (different
rules for inlines, wrt. to boxes).

"for clipping" makes me think of the overflow and clip properties, but I think
this is only about clipPath? So maybe referenceBoxRectForClipPath() would be
better? Not sure if motion path would also use it.

> Source/WebCore/rendering/RenderLayer.h:927
> +    bool rendererNeedsPixelSnapping() const;
> +    FloatRect snapRectToDevicePixelsIfNeeded(const LayoutRect&) const;
> +    FloatRect snapRectToDevicePixelsIfNeeded(const FloatRect&) const;

I think these should be free functions somewhere, and not functions of
RenderLayer.


More information about the webkit-reviews mailing list