[webkit-reviews] review granted: [Bug 230666] Unify more media-related WebCore source files : [Attachment 439011] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 22 23:11:22 PDT 2021

Tim Horton <thorton at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 230666: Unify more media-related WebCore source files

Attachment 439011: Patch


--- Comment #2 from Tim Horton <thorton at apple.com> ---
Comment on attachment 439011
  --> https://bugs.webkit.org/attachment.cgi?id=439011

View in context: https://bugs.webkit.org/attachment.cgi?id=439011&action=review

> -static const NSString *PlaybackSessionIdKey = @"PlaybackSessionID";

IIRC one of the other common semi-hacky answers was to stick (part of) the
filename in it somewhere. Ideally of course it would come from some other file
to avoid this problem...

> -static bool isEqual(Uint8Array* data, const char* literal)
> +static bool isEqual2(Uint8Array* data, const char* literal)

Ditto the "maybe file name or some other context instead of weird suffixes"

More information about the webkit-reviews mailing list