[webkit-reviews] review granted: [Bug 230486] Use typed identifier for WebSocketChannel identifiers : [Attachment 438692] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 21 00:10:03 PDT 2021


youenn fablet <youennf at gmail.com> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 230486: Use typed identifier for WebSocketChannel identifiers
https://bugs.webkit.org/show_bug.cgi?id=230486

Attachment 438692: Patch

https://bugs.webkit.org/attachment.cgi?id=438692&action=review




--- Comment #2 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 438692
  --> https://bugs.webkit.org/attachment.cgi?id=438692
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=438692&action=review

> Source/WebCore/Modules/websockets/ThreadableWebSocketChannel.h:87
> +    virtual WebSocketChannelIdentifier progressIdentifier() const = 0;

Can we rename progressIdentifier as well to just identifier?

> Source/WebCore/Modules/websockets/WebSocketChannelInspector.cpp:37
> +    : m_progressIdentifier(WebSocketChannelIdentifier::generateThreadSafe())
{ }

I would have thought only WebSocketChannel would generate
WebSocketChannelIdentifier, it is a bit odd but is a preexisting issue.


More information about the webkit-reviews mailing list