[webkit-reviews] review granted: [Bug 230078] Move some profiling to UnlinkedCodeBlock : [Attachment 438391] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Sep 16 13:17:54 PDT 2021
Yusuke Suzuki <ysuzuki at apple.com> has granted Saam Barati <sbarati at apple.com>'s
request for review:
Bug 230078: Move some profiling to UnlinkedCodeBlock
https://bugs.webkit.org/show_bug.cgi?id=230078
Attachment 438391: Patch
https://bugs.webkit.org/attachment.cgi?id=438391&action=review
--- Comment #32 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 438391
--> https://bugs.webkit.org/attachment.cgi?id=438391
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=438391&action=review
r=me
> Source/JavaScriptCore/bytecode/ValueProfile.h:220
> +struct UnlinkedValueProfile {
I think `class` is better in this case.
> Source/JavaScriptCore/runtime/CachedTypes.cpp:2164
> + m_valueProfiles =
FixedVector<UnlinkedValueProfile>(cachedCodeBlock.numValueProfiles());
> + m_arrayProfiles =
FixedVector<UnlinkedArrayProfile>(cachedCodeBlock.numArrayProfiles());
Why not initializing them in the initializer list?
, m_valueProfiles(cachedCodeBlock.numValueProfiles())
More information about the webkit-reviews
mailing list