[webkit-reviews] review granted: [Bug 230058] Use std::not_fn instead of lambda in URLParser : [Attachment 437877] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 10 15:28:23 PDT 2021


Darin Adler <darin at apple.com> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 230058: Use std::not_fn instead of lambda in URLParser
https://bugs.webkit.org/show_bug.cgi?id=230058

Attachment 437877: Patch

https://bugs.webkit.org/attachment.cgi?id=437877&action=review




--- Comment #18 from Darin Adler <darin at apple.com> ---
Comment on attachment 437877
  --> https://bugs.webkit.org/attachment.cgi?id=437877
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=437877&action=review

> Source/WTF/wtf/URLParser.cpp:2710
> +	       return segment.find(std::not_fn(isASCIIHexDigit<UChar>), 2) ==
notFound;

find == notFound is harder to read than !contains; can we add/use contains
instead?


More information about the webkit-reviews mailing list