[webkit-reviews] review granted: [Bug 231645] add test for bug 231353 : [Attachment 441018] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 13 11:06:23 PDT 2021


youenn fablet <youennf at gmail.com> has granted Cameron McCormack (:heycam)
<heycam at apple.com>'s request for review:
Bug 231645: add test for bug 231353
https://bugs.webkit.org/show_bug.cgi?id=231645

Attachment 441018: Patch

https://bugs.webkit.org/attachment.cgi?id=441018&action=review




--- Comment #4 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 441018
  --> https://bugs.webkit.org/attachment.cgi?id=441018
Patch

r=me once bots are happy

View in context: https://bugs.webkit.org/attachment.cgi?id=441018&action=review

> LayoutTests/webrtc/captureStream-color-space.html:10
> +    let srcContext = src.getContext("2d");

Could use const I guess here and below.

> LayoutTests/webrtc/captureStream-color-space.html:28
> +    assert_array_approx_equals(actual, expected, 2, `actual = ${actual},
expected = ${expected}`);

If this fails, we probably never hit t.done().
Maybe 2 is too small.

> LayoutTests/webrtc/captureStream-color-space.html:32
> +var t = async_test(function(t) {

Could use async_test(async function...

> LayoutTests/webrtc/captureStream-color-space.html:45
> +    local.createOffer().then(function(desc) {

You could write it with await in a more readable way


More information about the webkit-reviews mailing list