[webkit-reviews] review granted: [Bug 231676] Implement FileSystemHandle move() : [Attachment 441092] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 13 10:04:33 PDT 2021


youenn fablet <youennf at gmail.com> has granted Sihui Liu <sihui_liu at apple.com>'s
request for review:
Bug 231676: Implement FileSystemHandle move()
https://bugs.webkit.org/show_bug.cgi?id=231676

Attachment 441092: Patch

https://bugs.webkit.org/attachment.cgi?id=441092&action=review




--- Comment #5 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 441092
  --> https://bugs.webkit.org/attachment.cgi?id=441092
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=441092&action=review

> Source/WebCore/ChangeLog:9
> +	   Provide a way to move an existing file to a new place in OPFS.

APFS?

> Source/WebCore/Modules/filesystemaccess/FileSystemHandle.cpp:66
> +	   promise.settle(WTFMove(result));

As a future refactoring, we should probably enqueue a task to resolve the
promises. That will make sure we do this in the event loop.

> Source/WebKit/NetworkProcess/storage/FileSystemStorageHandle.cpp:77
> +    return !(name == "." || name == ".." || name.contains(pathSeparator));

Might be easier to read as: name != "." && name != ".." &&
!name.containts(pathSeparator).

> Source/WebKit/NetworkProcess/storage/FileSystemStorageHandle.cpp:108
> +    // Do not remove file if there is open access handle as web process may
be performing oeprations.

s/oeprations/operations/

> Source/WebKit/NetworkProcess/storage/FileSystemStorageHandle.cpp:110
> +	   return FileSystemStorageError::InvalidState;

Do we have a test for it?

> Source/WebKit/NetworkProcess/storage/FileSystemStorageHandle.cpp:273
> +	   return FileSystemStorageError::InvalidState;

Do we have a test for it?

> Source/WebKit/NetworkProcess/storage/FileSystemStorageHandle.cpp:283
> +	   return FileSystemStorageError::InvalidName;

Do we have a test for it?


More information about the webkit-reviews mailing list