[webkit-reviews] review granted: [Bug 231489] [Build-time perf] Forward-declare more things in Document.h : [Attachment 440891] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 11 22:50:40 PDT 2021


Myles C. Maxfield <mmaxfield at apple.com> has granted Jer Noble
<jer.noble at apple.com>'s request for review:
Bug 231489: [Build-time perf] Forward-declare more things in Document.h
https://bugs.webkit.org/show_bug.cgi?id=231489

Attachment 440891: Patch

https://bugs.webkit.org/attachment.cgi?id=440891&action=review




--- Comment #5 from Myles C. Maxfield <mmaxfield at apple.com> ---
Comment on attachment 440891
  --> https://bugs.webkit.org/attachment.cgi?id=440891
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=440891&action=review

Please make EWS green before landing.

> Source/WebCore/dom/Node.cpp:2296
> -		   result.iterator->value |= deliveryOptions;
> +		   result.iterator->value.add(deliveryOptions);

Why? (there are other similar things in this patch, too)

> Source/WebCore/page/MediaProducer.h:34
> +enum class MediaProducerMediaState : uint32_t {

Is there really no better name than this?

> Source/WebCore/page/MediaProducer.h:59
> +enum class MediaProducerMediaCaptureKind : uint8_t {

And this


More information about the webkit-reviews mailing list