[webkit-reviews] review granted: [Bug 233023] Implement custom element definition's *disable shadow* flag : [Attachment 444037] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 12 09:59:48 PST 2021


Geoffrey Garen <ggaren at apple.com> has granted  review:
Bug 233023: Implement custom element definition's *disable shadow* flag
https://bugs.webkit.org/show_bug.cgi?id=233023

Attachment 444037: Patch

https://bugs.webkit.org/attachment.cgi?id=444037&action=review




--- Comment #3 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 444037
  --> https://bugs.webkit.org/attachment.cgi?id=444037
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=444037&action=review

r=me

> Source/WebCore/bindings/js/JSCustomElementInterface.cpp:53
> +    , m_isShadowDisabled(false)

I have a style preference for boolean conditions to be named in the
affirmative, to avoid double negatives. So I would call this "isShadowEnabled",
and initialize to true. But I guess the is the spec API name, so I'll ignore my
preference here.

> Source/WebCore/bindings/js/JSCustomElementInterface.h:111
> +    bool m_isShadowDisabled : 1;

Usually we don't do : 1 until there are more booleans to pack; but you
mentioned that the follow-up patch will add them, so this is OK to me.


More information about the webkit-reviews mailing list