[webkit-reviews] review granted: [Bug 231321] EnumeratorGetByVal for IndexedMode+OwnStructureMode doesn't always recover the property name : [Attachment 443027] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 1 16:06:04 PDT 2021


Yusuke Suzuki <ysuzuki at apple.com> has granted Saam Barati <sbarati at apple.com>'s
request for review:
Bug 231321: EnumeratorGetByVal for IndexedMode+OwnStructureMode doesn't always
recover the property name
https://bugs.webkit.org/show_bug.cgi?id=231321

Attachment 443027: patch

https://bugs.webkit.org/attachment.cgi?id=443027&action=review




--- Comment #3 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 443027
  --> https://bugs.webkit.org/attachment.cgi?id=443027
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=443027&action=review

r=me

> Source/JavaScriptCore/dfg/DFGSpeculativeJIT.cpp:15908
> +	       MacroAssembler::JumpList& genericOrRecoverCase =
m_graph.varArgChild(node, 1).node() == m_graph.varArgChild(node, 3).node() ?
recoverGenericCase : notFastNamedCases;

For readability, let's define `bool indexedModeAndOwnStructureMode = ...` and
use it.

> Source/JavaScriptCore/ftl/FTLLowerDFGToB3.cpp:13686
> +	   // FIXME: This is a pretty bad way to say we're using
IndexedMode+OwnStructureMode mode. 

Ditto for bool variable.

> Source/JavaScriptCore/ftl/FTLLowerDFGToB3.cpp:13755
> +	   if (indexEdge.node() == propertyNameEdge.node()) {

Use bool variable which should be defined above.


More information about the webkit-reviews mailing list