[webkit-reviews] review granted: [Bug 223183] Add a new delegate for geolocation permission : [Attachment 423185] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 15 11:04:43 PDT 2021


Eric Carlson <eric.carlson at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 223183: Add a new delegate for geolocation permission
https://bugs.webkit.org/show_bug.cgi?id=223183

Attachment 423185: Patch

https://bugs.webkit.org/attachment.cgi?id=423185&action=review




--- Comment #5 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 423185
  --> https://bugs.webkit.org/attachment.cgi?id=423185
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=423185&action=review

> Source/WebKit/UIProcess/Cocoa/UIDelegate.mm:415
> +	   [(id <WKUIDelegatePrivate>)delegate
_webView:m_uiDelegate->m_webView.get().get()
requestGeolocationPermissionForOrigin:wrapper(API::SecurityOrigin::create(secur
ityOrigin.get())) initiatedByFrame:wrapper(API::FrameInfo::create(FrameInfoData
{ frameInfo }, &page)) decisionHandler:makeBlockPtr([completionHandler =
std::exchange(completionHandler, nullptr), securityOrigin =
securityOrigin->data(), checker = WTFMove(checker), page = makeWeakPtr(page)]
(_WKPermissionDecision decision) mutable {

This is *much* harder to read and understand than the one you updated for
`UIClient::decidePolicyForUserMediaPermissionRequest`, so it might be worth
using a local variable or two to aid readability.


More information about the webkit-reviews mailing list