[webkit-reviews] review granted: [Bug 227182] Move rectForPoint() static function out from the HitTestLocation class : [Attachment 431799] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 20 09:47:59 PDT 2021


Sam Weinig <sam at webkit.org> has granted zalan <zalan at apple.com>'s request for
review:
Bug 227182: Move rectForPoint() static function out from the HitTestLocation
class
https://bugs.webkit.org/show_bug.cgi?id=227182

Attachment 431799: Patch

https://bugs.webkit.org/attachment.cgi?id=431799&action=review




--- Comment #2 from Sam Weinig <sam at webkit.org> ---
Comment on attachment 431799
  --> https://bugs.webkit.org/attachment.cgi?id=431799
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=431799&action=review

> Source/WebCore/ChangeLog:7
> +

Please add a short why here.

> Source/WebCore/rendering/HitTestLocation.cpp:29
> +    IntPoint actualPoint(flooredIntPoint(point));

Could be slightly nicer by using assignment + auto to avoid stating IntPoint
twice. (I do realize you are just moving it, but still).

> Source/WebCore/rendering/HitTestLocation.cpp:37
> +    return IntRect(actualPoint, actualPadding);

This could probably just be return { actualPoint, actualPadding };


More information about the webkit-reviews mailing list