[webkit-reviews] review granted: [Bug 226544] Drop legacy ActiveDOMObject::setPendingActivity() / unsetPendingActivity() : [Attachment 430375] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 2 12:39:07 PDT 2021


Darin Adler <darin at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 226544: Drop legacy ActiveDOMObject::setPendingActivity() /
unsetPendingActivity()
https://bugs.webkit.org/show_bug.cgi?id=226544

Attachment 430375: Patch

https://bugs.webkit.org/attachment.cgi?id=430375&action=review




--- Comment #2 from Darin Adler <darin at apple.com> ---
Comment on attachment 430375
  --> https://bugs.webkit.org/attachment.cgi?id=430375
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=430375&action=review

> Source/WebCore/Modules/applepay/ApplePaySession.cpp:791
> +    auto protectedJSWrapper = makePendingActivity(*this);

This object is not itself a JS wrapper. It is an object that protects the
wrapper. So naming it "protected JS wrapper" is not quite right.

> Source/WebCore/Modules/mediasource/MediaSource.h:182
> +    unsigned m_associatedRegistryCount { 0 };

Do we have a no-overflow guarantee? 32-bits is a lot of bits, but is it
guaranteed enough?

> Source/WebCore/page/EventSource.cpp:278
> +    auto protectedJSWrapper = makePendingActivity(*this);

Same variable name thought.


More information about the webkit-reviews mailing list