[webkit-reviews] review granted: [Bug 221255] Add a loader for <model> resources : [Attachment 419003] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 2 08:54:46 PST 2021


youenn fablet <youennf at gmail.com> has granted Antoine Quint
<graouts at webkit.org>'s request for review:
Bug 221255: Add a loader for <model> resources
https://bugs.webkit.org/show_bug.cgi?id=221255

Attachment 419003: Patch

https://bugs.webkit.org/attachment.cgi?id=419003&action=review




--- Comment #8 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 419003
  --> https://bugs.webkit.org/attachment.cgi?id=419003
Patch

r=me once bots are happy.
Can you file a bug to keep track of adding a service worker destination test
for model?

View in context: https://bugs.webkit.org/attachment.cgi?id=419003&action=review

> Source/WebCore/loader/MediaResourceLoader.h:71
> +    FetchOptions::Destination m_destination;

Might need FetchOptions.h include for non unified builds.

> Source/WebCore/loader/cache/CachedResource.h:184
> +    bool isMainOrMediaOrIconOrRawResource() const

Sounds good. Ideally we would move the definition to an inline method in the
header:
class {
    bool isMainOrMediaOrIconOrRawResource() const;
};

inline bool CachedResource::isMainOrMediaOrIconOrRawResource() const
{
    return ...
}

> Source/WebCore/loader/cache/CachedResourceLoader.cpp:326
> +    CachedResource::Type resourceType = CachedResource::Type::ModelResource;

auto.
And should probably MediaResource here instead of ModelResource.

> Source/WebKit/NetworkProcess/NetworkResourceLoader.cpp:397
> +	       return ResourceLoadInfo::Type::Other;

Media might be better than Other here?


More information about the webkit-reviews mailing list