[webkit-reviews] review granted: [Bug 234324] Clean-up: Adopt Page::forEachDocument in some missed spots : [Attachment 447278] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 15 12:56:21 PST 2021


Darin Adler <darin at apple.com> has granted Brent Fulgham <bfulgham at webkit.org>'s
request for review:
Bug 234324: Clean-up: Adopt Page::forEachDocument in some missed spots
https://bugs.webkit.org/show_bug.cgi?id=234324

Attachment 447278: Patch

https://bugs.webkit.org/attachment.cgi?id=447278&action=review




--- Comment #9 from Darin Adler <darin at apple.com> ---
Comment on attachment 447278
  --> https://bugs.webkit.org/attachment.cgi?id=447278
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=447278&action=review

Looks really good.

> Source/WebCore/page/Page.h:895
> +    static void forEachDocumentFromFrame(const Frame&, const
Function<void(Document&)>&);

The callers all seem to be passing the main frame, although orientationChanged
doesn’t make it explicit. I suggest we say "FromMainFrame" here.

> Source/WebCore/page/Page.h:896
> +    void forEachFrameFromMainFrame(const Function<void(Frame&)>&);

This could just be named forEachFrame without mention of the main frame; I
don’t see any main frame here.


More information about the webkit-reviews mailing list