[webkit-reviews] review granted: [Bug 234060] Make FontCache::invalidateAllFontCaches call invalidate on all worker FontCaches : [Attachment 446481] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 8 19:00:05 PST 2021


Darin Adler <darin at apple.com> has granted Cameron McCormack (:heycam)
<heycam at apple.com>'s request for review:
Bug 234060: Make FontCache::invalidateAllFontCaches call invalidate on all
worker FontCaches
https://bugs.webkit.org/show_bug.cgi?id=234060

Attachment 446481: Patch

https://bugs.webkit.org/attachment.cgi?id=446481&action=review




--- Comment #2 from Darin Adler <darin at apple.com> ---
Comment on attachment 446481
  --> https://bugs.webkit.org/attachment.cgi?id=446481
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446481&action=review

> Source/WebCore/platform/graphics/FontCache.cpp:397
> +static void callOnAllFontCaches(F function)

Can we use WTF::function instead of making this entire thing a template?

Is "call" really the right way to describe something that posts tasks on the
run loop?

> Source/WebCore/platform/graphics/FontCache.cpp:417
> +void FontCache::invalidateAllFontCaches()
> +{
> +    callOnAllFontCaches([](FontCache& fontCache) {
> +	   fontCache.invalidate();
> +    });
>  }

For the purposes that callers intend, is it OK that this posts tasks that
invalidate the font caches in the future, and doesn’t finish invalidating them
before returning? Should we change the name to make that clearer?


More information about the webkit-reviews mailing list