[webkit-reviews] review granted: [Bug 233931] Use Span for IPC::ArrayReference and DataReference : [Attachment 446195] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 8 14:49:41 PST 2021


Wenson Hsieh <wenson_hsieh at apple.com> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 233931: Use Span for IPC::ArrayReference and DataReference
https://bugs.webkit.org/show_bug.cgi?id=233931

Attachment 446195: Patch

https://bugs.webkit.org/attachment.cgi?id=446195&action=review




--- Comment #3 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 446195
  --> https://bugs.webkit.org/attachment.cgi?id=446195
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446195&action=review

> Source/WTF/wtf/Vector.h:657
> +    Vector(Span<const T> span)

Would it be better to take a `const Span<const T>&` instead?

> Source/WebKit/UIProcess/API/Cocoa/WKWebView.mm:1643
> +	   if (pdfData.empty()) {

It does seem a bit odd that while Span uses `bool empty()`, all other WTF
classes use `bool isEmpty()`. Maybe we should rename this for consistency at
some point..


More information about the webkit-reviews mailing list