[webkit-reviews] review granted: [Bug 233890] Add support for `navigator.requestCookieConsent()` behind a disabled feature flag : [Attachment 446083] Adjust ChangeLog

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 7 14:27:49 PST 2021


Darin Adler <darin at apple.com> has granted Wenson Hsieh
<wenson_hsieh at apple.com>'s request for review:
Bug 233890: Add support for `navigator.requestCookieConsent()` behind a
disabled feature flag
https://bugs.webkit.org/show_bug.cgi?id=233890

Attachment 446083: Adjust ChangeLog

https://bugs.webkit.org/attachment.cgi?id=446083&action=review




--- Comment #6 from Darin Adler <darin at apple.com> ---
Comment on attachment 446083
  --> https://bugs.webkit.org/attachment.cgi?id=446083
Adjust ChangeLog

View in context: https://bugs.webkit.org/attachment.cgi?id=446083&action=review

> Source/WebCore/Modules/cookie-consent/NavigatorCookieConsent.h:37
> +class DeferredPromise;
> +class Navigator;
> +struct RequestCookieConsentOptions;

I typically put a blank line between class and struct.

> Source/WebCore/Modules/cookie-consent/RequestCookieConsentOptions.h:28
> +#include "VoidCallback.h"

Can we forward-declare VoidCallback instead of including the header? We want to
resist including headers in headers as much as we can.

> Source/WebCore/page/ChromeClient.h:27
> +#include "CookieConsentDecisionResult.h"

Can’t we use this instead?

enum class CookieConsentDecisionResult : uint8_t;

> Source/WebKit/UIProcess/API/APIUIClient.h:33
> +#include <WebCore/CookieConsentDecisionResult.h>

Can’t we use this instead?

enum class CookieConsentDecisionResult : uint8_t;


More information about the webkit-reviews mailing list