[webkit-reviews] review granted: [Bug 229488] Re-generalize top layer element concept : [Attachment 436377] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 27 08:38:06 PDT 2021

Antti Koivisto <koivisto at iki.fi> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 229488: Re-generalize top layer element concept

Attachment 436377: Patch


--- Comment #3 from Antti Koivisto <koivisto at iki.fi> ---
Comment on attachment 436377
  --> https://bugs.webkit.org/attachment.cgi?id=436377

View in context: https://bugs.webkit.org/attachment.cgi?id=436377&action=review

> Source/WebCore/dom/Element.cpp:3398
> +    invalidateStyle();

I think this can use invalidateStyleInternal(). The difference is that
invalidateStyle() may also invalidate siblings. That is only needed for things
that flip pseudo classes (yes, these need better names).

More information about the webkit-reviews mailing list