[webkit-reviews] review granted: [Bug 229018] Add thread safe version of CanMakeCheckedPtr : [Attachment 435397] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 12 16:22:55 PDT 2021


Geoffrey Garen <ggaren at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 229018: Add thread safe version of CanMakeCheckedPtr
https://bugs.webkit.org/show_bug.cgi?id=229018

Attachment 435397: Patch

https://bugs.webkit.org/attachment.cgi?id=435397&action=review




--- Comment #4 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 435397
  --> https://bugs.webkit.org/attachment.cgi?id=435397
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=435397&action=review

r=me

> Source/WTF/wtf/CheckedRef.h:253
> +    operator IntegralType() const { assertThread(); return m_value; }
> +    bool operator!() const { assertThread(); return !m_value; }
> +    SingleThreadIntegralWrapper& operator++() { assertThread(); m_value++;
return *this; }
> +    SingleThreadIntegralWrapper& operator--() { assertThread(); m_value--;
return *this; }

We can probably afford one line per statement for readability here.


More information about the webkit-reviews mailing list