[webkit-reviews] review granted: [Bug 216131] Webpages flash when getting closed : [Attachment 408466] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 10 12:13:28 PDT 2020


Chris Dumez <cdumez at apple.com> has granted Sihui Liu <sihui_liu at apple.com>'s
request for review:
Bug 216131: Webpages flash when getting closed
https://bugs.webkit.org/show_bug.cgi?id=216131

Attachment 408466: Patch

https://bugs.webkit.org/attachment.cgi?id=408466&action=review




--- Comment #25 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 408466
  --> https://bugs.webkit.org/attachment.cgi?id=408466
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=408466&action=review

> Source/WebKit/UIProcess/WebPageProxy.cpp:1160
> +    RunLoop::current().dispatch([destinationID =
messageSenderDestinationID(), protectedProcess = m_process.copyRef(), token =
m_process->shutdownPreventingScopeCount()] {

token is too generic. Maybe preventShutdownScope?

> Source/WebKit/UIProcess/WebPageProxy.cpp:3322
> +	       auto preventNavigationProcessShutdownToken =
processForNavigation->shutdownPreventingScopeCount();

I don't think we need to add this Token suffix.

> Source/WebKit/UIProcess/WebProcessProxy.cpp:204
> +    , m_shutdownPreventingScopeCounter([this](RefCounterEvent) {
maybeShutDown(); })

if (event == RefCounterEvent::decrement) maybeShutDown();

> Source/WebKit/UIProcess/WebProcessProxy.h:298
> +    typedef RefCounter<ShutdownPreventingScopeType>
ShutdownPreventingScopeCounter;

using ShutdownPreventingScopeCounter = RefCounter<ShutdownPreventingScopeType>;

> Source/WebKit/UIProcess/WebProcessProxy.h:299
> +    ShutdownPreventingScopeCounter::Token shutdownPreventingScopeCount() {
return m_shutdownPreventingScopeCounter.count(); }

I would call this shutdownPreventingScope(), I don't think "count" is helpful
here.


More information about the webkit-reviews mailing list