[webkit-reviews] review granted: [Bug 216050] Make sure BiquadFilterNode tail is getting processed : [Attachment 407710] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 1 14:55:45 PDT 2020
Darin Adler <darin at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 216050: Make sure BiquadFilterNode tail is getting processed
https://bugs.webkit.org/show_bug.cgi?id=216050
Attachment 407710: Patch
https://bugs.webkit.org/attachment.cgi?id=407710&action=review
--- Comment #2 from Darin Adler <darin at apple.com> ---
Comment on attachment 407710
--> https://bugs.webkit.org/attachment.cgi?id=407710
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=407710&action=review
> Source/WebCore/Modules/webaudio/PannerNode.cpp:547
> + return m_panner ? m_panner->requiresTailProcessing() : true;
I would write this as:
return !m_panner || m_panner->requiresTailProcessing();
For me that seems more readable. Maybe other people find the ? : form more
readable?
> Source/WebCore/Modules/webaudio/WebKitAudioPannerNode.cpp:355
> + return m_panner ? m_panner->requiresTailProcessing() : true;
Ditto.
More information about the webkit-reviews
mailing list