[webkit-reviews] review granted: [Bug 218265] AudioBuffer.getChannelData(x) should keep returning the same JS wrapper for a given channel : [Attachment 412473] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 27 16:13:20 PDT 2020


Geoffrey Garen <ggaren at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 218265: AudioBuffer.getChannelData(x) should keep returning the same JS
wrapper for a given channel
https://bugs.webkit.org/show_bug.cgi?id=218265

Attachment 412473: Patch

https://bugs.webkit.org/attachment.cgi?id=412473&action=review




--- Comment #5 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 412473
  --> https://bugs.webkit.org/attachment.cgi?id=412473
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=412473&action=review

r=me

> Source/WebCore/Modules/webaudio/AudioBuffer.cpp:156
> +void AudioBuffer::visitChannelsWrappers(JSC::SlotVisitor& visitor)

Also visitChannelWrappers

> Source/WebCore/Modules/webaudio/AudioBuffer.h:82
> +    Vector<JSValueInWrappedObject> m_channelsWrappers;

I would call this m_channelWrappers. Each wrapper wraps one channel.


More information about the webkit-reviews mailing list