[webkit-reviews] review granted: [Bug 218108] Use WorkerOrWorkletGlobalScope in WebInspector code instead of WorkerGlobalScope : [Attachment 412144] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 22 16:58:52 PDT 2020


Darin Adler <darin at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 218108: Use WorkerOrWorkletGlobalScope in WebInspector code instead of
WorkerGlobalScope
https://bugs.webkit.org/show_bug.cgi?id=218108

Attachment 412144: Patch

https://bugs.webkit.org/attachment.cgi?id=412144&action=review




--- Comment #2 from Darin Adler <darin at apple.com> ---
Comment on attachment 412144
  --> https://bugs.webkit.org/attachment.cgi?id=412144
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=412144&action=review

> Source/WebCore/inspector/InspectorInstrumentation.h:102
> +class WorkerOrWorkletGlobalScope;

Sure makes me wish we had a shorter name for this: Workerlikes or whatever.

> Source/WebCore/inspector/InspectorInstrumentation.h:544
> +    static InstrumentingAgents& instrumentingAgentsFor(Page&);
> +    static InstrumentingAgents&
instrumentingAgentsFor(WorkerOrWorkletGlobalScope&);
> +
> +    static InstrumentingAgents* instrumentingAgentsFor(const Frame&);
> +    static InstrumentingAgents* instrumentingAgentsFor(const Frame*);
> +    static InstrumentingAgents*
instrumentingAgentsFor(ScriptExecutionContext*);
> +    static InstrumentingAgents*
instrumentingAgentsFor(ScriptExecutionContext&);
> +    static InstrumentingAgents* instrumentingAgentsFor(Document&);
> +    static InstrumentingAgents* instrumentingAgentsFor(Document*);
> +    static InstrumentingAgents* instrumentingAgentsFor(RenderObject&);
> +    static InstrumentingAgents*
instrumentingAgentsFor(WorkerOrWorkletGlobalScope*);

Great to use overloading. Just wondering, why did you decide to keep the word
"For"?


More information about the webkit-reviews mailing list