[webkit-reviews] review granted: [Bug 215158] ResizeObserver appears to not be properly garbage collected : [Attachment 411961] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 21 02:35:23 PDT 2020

Frédéric Wang (:fredw) <fred.wang at free.fr> has granted cathiechen
<cathiechen at igalia.com>'s request for review:
Bug 215158: ResizeObserver appears to not be properly garbage collected

Attachment 411961: Patch


--- Comment #14 from Frédéric Wang (:fredw) <fred.wang at free.fr> ---
Comment on attachment 411961
  --> https://bugs.webkit.org/attachment.cgi?id=411961

View in context: https://bugs.webkit.org/attachment.cgi?id=411961&action=review

> Source/WebCore/ChangeLog:8
> +	   If ResizeObserver is referenced inside ResizeObserverCallback, they
are not garbage collected properly. To fix this,

If a ResizeObserver ... it is not garbage...


ResizeObservers ... they are not

> LayoutTests/resize-observer/resize-observer-callback-leak.html:11
> +function test0() {

can you find a better name than "test0"?

> LayoutTests/resize-observer/resize-observer-callback-leak.html:30
> +	   }

I don't understand  this handler variable? Is it duplicating the handler below?

More information about the webkit-reviews mailing list