[webkit-reviews] review granted: [Bug 217242] Update Worklet.addModule() to actually fetch and evaluate the module script : [Attachment 410392] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 5 15:07:25 PDT 2020


Geoffrey Garen <ggaren at apple.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 217242: Update Worklet.addModule() to actually fetch and evaluate the
module script
https://bugs.webkit.org/show_bug.cgi?id=217242

Attachment 410392: Patch

https://bugs.webkit.org/attachment.cgi?id=410392&action=review




--- Comment #10 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 410392
  --> https://bugs.webkit.org/attachment.cgi?id=410392
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=410392&action=review

r=me

> Source/WebCore/Modules/webaudio/AudioWorkletGlobalScope.h:56
> +    AudioWorkletThread* workerOrWorkletThread() final { return
m_thread.ptr(); }

I would just call this "thread". But if you prefer to call it
"workerOrWorkletThread", let's rename the data member to match:
m_workerOrWorkletThread.

> Source/WebCore/Modules/webaudio/AudioWorkletThread.h:66
> +    Ref<AudioWorkletMessagingProxy> m_messagingProxy;

It seems like AudioWorkletMessagingProxy and AudioWorkletThread ref each other.
Is this a cycle?


More information about the webkit-reviews mailing list