[webkit-reviews] review granted: [Bug 218427] [GPU Process] Control the life cycle of the platform image by a new class named NativeImage : [Attachment 413566] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 9 13:41:30 PST 2020


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Said Abou-Hallawa
<sabouhallawa at apple.com>'s request for review:
Bug 218427: [GPU Process] Control the life cycle of the platform image by a new
class named NativeImage
https://bugs.webkit.org/show_bug.cgi?id=218427

Attachment 413566: Patch

https://bugs.webkit.org/attachment.cgi?id=413566&action=review




--- Comment #26 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 413566
  --> https://bugs.webkit.org/attachment.cgi?id=413566
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=413566&action=review

> Source/WebCore/platform/graphics/NativeImage.h:37
> +class NativeImage : public RefCounted<NativeImage> {

WTF_MAKE_FAST_ALLOCATED

> Source/WebCore/platform/graphics/cg/GraphicsContextGLCG.cpp:341
> +    RetainPtr<CGImageRef> image = m_cgImage->platformImage();

The member variable isn't a CGImage any more, so maybe rename it.

> Source/WebCore/platform/graphics/cg/GraphicsContextGLCG.cpp:376
> +    image = m_cgImage->platformImage();

Hard to see where 'image' comes from.

> Source/WebKitLegacy/mac/DOM/DOM.mm:539
> +	       RetainPtr<CGImageRef> contentImage =
image->nativeImage()->platformImage();

auto?


More information about the webkit-reviews mailing list