[webkit-reviews] review denied: [Bug 212115] Use OptionSet<DragDestinationAction> for mask values : [Attachment 400121] Patch v4

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 25 11:17:26 PDT 2020


Alex Christensen <achristensen at apple.com> has denied David Kilzer (:ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 212115: Use OptionSet<DragDestinationAction> for mask values
https://bugs.webkit.org/show_bug.cgi?id=212115

Attachment 400121: Patch v4

https://bugs.webkit.org/attachment.cgi?id=400121&action=review




--- Comment #20 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 400121
  --> https://bugs.webkit.org/attachment.cgi?id=400121
Patch v4

View in context: https://bugs.webkit.org/attachment.cgi?id=400121&action=review

I think this adds too much complexity to OptionSet.  Let's push this complexity
towards DragDestinationAction.
I think OptionSetValues should be added in a different patch.  Right now
OptionSet serialization is basically unchecked and that's not a known issue
because if a compromised process sends invalid bits, they won't be used.

> Source/WTF/wtf/OptionSet.h:244
> +constexpr OptionSet<E> OptionSet<E>::any()

I don't think this is a good name for this.  Just because DragDestinationAction
had an any doesn't mean other enums call it "any".


More information about the webkit-reviews mailing list